Installing the Smart Client Software Factory

If you want to use all the assets in the Smart Client Software Factory, you need to install the prerequisites which include .NET Framework 3.5, Guidance Automation Extensions and SQL Server 2005 Compact Edition. You may also decide to install the optional components which include Guidance Automation Toolkit and Microsoft Visual Studio 2008 SDK if you want to modify the guidance package.

Installation Steps

Use the following steps to install the Smart Client Software Factory and its prerequisites:
Note: If you are in the evaluation stage, and you only want to review the documentation and source code, you do not need to download the dependencies.
  • Download and run the Smart Client Software Factory installer
install.png
  • Select the Check dependencies button from the splash screen (optional)
  • Select Next to install the factory from the Installer splash screen
DependencyChecker.png
  • Download any required components that are not on your machine (optional)
  • Download the optional components that are not on your machine (optional)
FeatureSelection.png
  • Note: If you want to install the documentation or source code, you do not need to install the prerequisites.
  • Note: You should download the Guidance Automation Toolkit if you want to modify the guidance package included in the factory.
  • Note: If you want to enable a May 2007 solution to April 2008 see the following: How to enable a May 2007 solution.

Last edited Apr 28, 2008 at 4:10 PM by mconverti, version 20

Comments

paralax Oct 4, 2009 at 5:54 PM 
The dependency checker crashes due to an unhandled DependencyChecker.Common.NotSupportedOperatingSystemException. {"The dependency checker does not contain any information on the dependencies for your current Operating System (build: 6002)"}
I'm using Vista SP 2 but other postings suggest that this also happens with Windows 7 builds. Please fix!

dan_b Jul 15, 2009 at 11:18 AM 
I have tried installing it with VS 2008 on Vista x64, with .Net 3.5 and SQL Server Compact Edition installed - it says I do not have visual studio or SQL Server compact edition....

pooran Jul 3, 2009 at 4:48 AM 
I tried installing it with VS.Net 2010 Beta 1 [Fresh Install.. nothing installed before].. it says C# not installed. I have only installed C# and Web Dev .. removed VB.Net, F#, VC++. Am I missing something,...

soorajpayyoor Mar 6, 2009 at 3:42 AM 
Hi,

I tried clicking the "Check dependencies" button and the DependencyChecker is crashing. I am using Win 7 beta with VS.NET 2008 Team System (version 9.0.30729.1 SP) and .NET framework 3.5 SP1. I have Visual Basic installed with VS.NET.

Regards
Sooraj Payyoormana

jonathan May 6, 2008 at 3:00 PM 
Hi BIKARAM,
- If you are using SCSF April 2008 you need to have Visual Studio 2008 Professional or Team System to use tests projects.
- If you are using a previous version of SCSF you need to have Visual Studio 2005 Team System to use tests projects.

For more information, please see the followings links
- Visual Studio 2005 Product Line Overview: http://msdn.microsoft.com/en-us/vs2005/aa700921.aspx
- Visual Studio 2008 Product Comparison: http://msdn.microsoft.com/en-us/vs2008/products/cc149003.aspx

Jonathan Cisneros
http://staff.southworks.net/blogs/jcisneros

BIKARAM Jan 17, 2008 at 3:26 PM 
If I tried to add a business module with test project for the module or open a hands on lab project which has test project. It says this type of project not supported in this installation.

Please do help to fix this issue.

sagblmi Jul 6, 2007 at 8:22 AM 
Is it possible to build Smart Client Application for win 2000 with this software factory? (being carefull to not use functionalities from NET3)

blainew May 31, 2007 at 8:42 PM 
There are issues with GAX and Visual Studio Orcas Beta1. We are working on making changes to GAX to support Visual Studio Orcas. Once this effort is completed, we will do some testing of the factory with Orcas.

Jaga May 31, 2007 at 4:37 PM 
I have tried to install the May release on a Virtual PC with VisualStudio Orcas Beta1 on it. The dependency check says: everything is OK, but during the installation I get following error: "This installer requires a version of Visual Studio 2005, which is not present on the computer." Is SCSF compatible with Orcas?

samiam May 30, 2007 at 11:07 AM 
aha - will install now

blainew May 24, 2007 at 3:32 PM 
Do you have Visual Basic .NET installed on your machine? We require Visual Basic .NET to be installed.

samiam May 24, 2007 at 8:05 AM 
I have tried to install the May release and get the following error at the end of the installation:
The project factory VisualBasic is not registered, template C:\Program Files\Microsoft Smart Client factory\Guidance Package\Templates\Projects\Module.Business.Tests.VB\Module.Tests.vstemplate cannot be installed.

I have all the dependancies in place. Any Ideas?