How to make Clickonce installer for SmartClient Software Factory applications

Topics: CAB & Smart Client Software Factory
Feb 27, 2007 at 12:37 AM
I deployed the application from visualstudio 2005,
In the Manifest Manager Utility (By Brian Noyes),
1.Selected the Shell.application file.
2.Deleted ProfileCatalog.xml from the list.
3.Added the modules and additional component dll files.
4.Selected the key and clicked Sign and Save button.
5.When I install from the publish.htm, it still shows the shell form, the views are not displaying.

Any help will be greatly appreciated.
Senthilvasan
Developer
Feb 27, 2007 at 1:27 PM
Edited Feb 27, 2007 at 6:31 PM
Hi,

If you are deleting the ProfileCatalog.xml, where are you loading the modules from?

Have you tried without deleting the ProfileCatalog.xml file?

Let me know if this helps,

Ezequiel Jadib
http://staff.southworks.net/blogs/ejadib
Feb 27, 2007 at 4:19 PM
I tried without deleting ProfileCatalog.xml aswell, it didn't work. I created a clickonce installer for GlobalBank application without the ProfileCatalog.xml, it worked.
Developer
Feb 27, 2007 at 6:49 PM
I assume you are using the standard functionality (ProfileCatalog.xml) to load the modules.

In that case you don't have to delete the ProfileCatalog.xml file. That file must be deployed as well.

Just be sure to include every module's dll (including the Infrastructure.Module) and keep unchecked the DataFile column in the Manifest Manager Utility for the ProfileCatalog.


Let me know if this helps,

Ezequiel Jadib
http://staff.southworks.net/blogs/ejadib
Feb 27, 2007 at 11:45 PM
Yes it is working now. There was a unused module reference in ProfileCatalog.xml which was not added in the deployment. After removing that reference from ProfileCatalog.xml, it worked.

Thanks for the help
Senthilvasan.