Server Returned an error

Topics: Updater Application Block
May 31, 2005 at 3:49 PM
originally posted by: Ready1

My UAB was working on IIS in windows 2000 but when i moved to windows xp SP2 i get an error of:

(404) Not found Error.

eg. the manifest is at : http://localhost/BDS/BDSmanifest.xml
I have directory browsing enabled but I cant use the full url to acess the manifest, but when browsing the directory i can....
May 31, 2005 at 7:28 PM
originally posted by: SlashDotNet

First, contrary to what other people have said, you don't have to have "directory browsing enabled" on the web virtual directory in order for the UAB to work. ( I am successfully using UAB and DO NOT have directory browsing enabled).

That being said, how are you "browsing the directory" and seeing the file? Using windows explorer with UNC naming? or browsing by pointing IE to http://localhost/BDS/BDSmanifest.xml ?
May 31, 2005 at 10:05 PM
originally posted by: Ready1

Hi SlashDotNet,

If I go to http://localhost/BDS/BDSmanifest.xml i get the 404 server error,.

But if i go to http://localhost/BDS/ (directory browsing enabled) and click on BDSmanifest.xml then it works.

Thanks,
Ready1
Jun 1, 2005 at 3:12 PM
originally posted by: Ready1

AnuragRastogi,

I dont have a urlscan folder in the inetserv folder. I cant see a trace either of a urlscan program.

Thanks,
Ready1
Jun 1, 2005 at 8:24 PM
originally posted by: AnuragRastogi

Hi
Can you please provide the stack trace of error and IIS Log after the file not found error occurs
Jun 1, 2005 at 8:33 PM
originally posted by: AnuragRastogi

.
Jun 2, 2005 at 3:04 AM
originally posted by: AnuragRastogi

Hi,

The probable cause of the error may be the existence of URLScan Security tool on your system that restricts the types of HTTP requests that Internet Information Services (IIS) will process.

You can check the existence of URLScan tool just on the currently installed programs in Add/Remove programs option in control panel.

You can follow the steps given for fixing the error-

•access the urlscan.ini file at following location-
“C:\<windows directory>\<system directory>\inetsrv\urlscan e.g.

“C:\WINDOWS\system32\inetsrv\urlscan\urlscan.ini”

•Edit this file by opening it in notepad.
•Remove the .exe verb from DenyExtensions listing.
•Put the .exe verb in AllowExtensions listing.
•Restart the IIS.

Let me know if it works for you.