UAB Limited to Windows XP Pro?

Topics: Updater Application Block
May 13, 2005 at 5:42 AM
originally posted by: InfiniteLoop

The doc says UAB requires Windows XP Pro. Does this just apply to my development environment, or does this mean that I can't use it if my application is required to work on Windows 2000?
May 13, 2005 at 11:32 PM
originally posted by: AnuragRastogi

Hi

UAB uses BITS downloader. BITS2.0 is already shipped with Windows XP SP2.

for UAB to work on Windows 2000 BITS 1.5 should be installed on that machine .

you can download the BITS 1.5 from following URL-

http://www.microsoft.com/downloads/details.aspx?FamilyID=8c6ef6c8-2abf-43c7-ab51-e0c53303086d&DisplayLang=en
May 17, 2005 at 5:11 AM
originally posted by: chester_cyyang

If you check updates before the application runs, I think a single thread customized web downloader is better than BITS. You don't have version problem of BITS.