Same old BITS problem, but fix isn't working

Topics: Updater Application Block
Oct 28, 2003 at 3:48 PM
originally posted by: JeffDeville

Ok, I'm getting the same error that appears to be the most prevalent:
BITSDownloader :
The BITS service returned an error for the job with the ID 'e03b1096-0b91-49e4-899a-4e44c58dc6b3'; ...

I'm running Win2k3, and I have installed BITS and WebDav. Updater can download my manifest file, and the files are parsed out of it. Then I have my temp directory created, and a bunch of 0kb temp files created. But then it dies, and the temp files are removed.

I've completely opened up my update directory to the anonymous user to the point that I can right-click and save any file to my computer (.dll, exe, or config)

I've associated .dll and .exe files w/ the asp.net engine.

I've no more suggestions to try that I can find... Thoughts?

I couldn't get this to work off of my XP machine for the same reason by the way.
Jan 6, 2004 at 6:34 PM
originally posted by: ramil_d

I get the same problem in my XP machine too....

-Ramil
Jan 14, 2004 at 6:13 AM
originally posted by: RohanSuperS

Same problem. Win XP.
Jan 14, 2004 at 7:04 AM
originally posted by: JeffDeville

Hey guys, check out my other post on instructions for Win 2k3 and XP. I should have cross-referenced it here already. They may help.
Jan 14, 2004 at 10:45 PM
originally posted by: RohanSuperS

I changed my IIS mappings, as suggested by Olismith, and it worked. No problem

Win XP client, win2K Server.
Jan 15, 2004 at 12:25 AM
originally posted by: ramil_d

RohanSuperS,

Are you downloading from a remote win2k server or just w/in your LAN?

Thanks.
Jan 15, 2004 at 12:28 AM
originally posted by: ramil_d

RohanSuperS,

Are you downloading from a remote win2k server or just w/in your LAN?

I had it working over our LAN but not in a Remote Web Server. I already tried the suggestion of Olismith and even from other threads but I still can't download the Server Manifest file.

Any more ideas?

TIA,
Ramil
Jan 15, 2004 at 12:41 AM
originally posted by: RohanSuperS

The W2k server is on the lan.

Maybe you should delete the .config file from the updated files, and see if it works then. If it does, then you know it has something to do with that file. If it still doesn't work, then you have a different problem all together.

Cheers
Rohan
Jan 15, 2004 at 12:43 AM
originally posted by: RohanSuperS

I just re-read your post, and you are saying you can't even download the manifest file? Correct?
Jan 15, 2004 at 1:01 AM
originally posted by: ramil_d

Yes I cant download the manifest file completely. I tried it over our LAN and it worked perfect. Haven't you tried it over a Remote Web Server?

TIA,
Ramil
Jan 15, 2004 at 1:07 AM
originally posted by: RohanSuperS

nope, unfortunately i have not tried it over a remote server. OurLAN doesn't allow me to access outside servers to upload stuff.

So I am assuming your error message is the same (the BITS problem) when yo are trying to download the manifest file. Do you have a mapping set up for .xml files?

Also, does the same thing happen when you allow all file extensions to be downloaded in IIS?
Jan 15, 2004 at 1:20 AM
originally posted by: ramil_d

I already removed the .config, .xml, .exe and .dll from the mappings but still a problem. I even added this file extensions to the registered file types in the HTTP Headers\MIME-Map option.

Btw, I noticed that a temp file is being created on my local pc, something like BIT999.tmp. I guess this is the Manifest file that was supposed to be downloaded but after awhile it disappears.

Any clue?

Cheers,
Ramil
Jan 15, 2004 at 1:32 AM
originally posted by: RohanSuperS

It does sound like it's trying to download the file. I think just to make sure it's not a MIME problem, open up all the extensions, by doing the following:

Note You should only add the wildcard mapping to the IIS MIME map as a temporary solution during troubleshooting. After you have determined that a missing MIME type is the cause of the issue, remove the wildcard mapping and add the specific mapping for the MIME type that you need to serve.
Open the IIS Microsoft Management Console (MMC), right-click the local computer name, and then click Properties.
Click MIME Types.
Click New.
In the Extension box, type an asterisk (*).
In the MIME Type box, type application/octet-stream.
Apply the new settings. Note that you must restart the World Wide Web Publishing Service or wait for the worker process to recycle for the changes to take effect

Cheers
Rohan
Jan 17, 2004 at 12:58 AM
originally posted by: ramil_d

Rohan,

Thanks for the input. You are correct. The problem had something to do with the MIME Types. By using .* I was able to download the Manifest file but not all files that should be downloaded were actually downloaded. I think I'm almost there. Again thank you for the help and I appreciate it alot.

Cheers.

Ramil
Jan 17, 2004 at 1:06 AM
originally posted by: RohanSuperS

Wonderful. Keep me informed.

Cheers
Rohan
Sep 10, 2004 at 7:47 AM
originally posted by: JohnAskew

Rohan,

The .* MIME type also worked for me when "The BITS service error message for this job is 'The requested URL does not exist on the server.'.".

I tried registering each file extension that I download, but that doesn't work.
I would like to replace the wildcard with more strict parameters, if possible.

Thanks for the help!