Server Requirement for Updater Application Block

Topics: Updater Application Block
Jul 16, 2003 at 7:00 AM
originally posted by: GDorazio

The web hosting company hosting my web site is not yet running Windows Server 2003 which is stated as a requirement for the Updater Application Block. Is this an absolute requirement or are there component(s) such as the .NET Framework or BITS that would need to be installed?

Jul 16, 2003 at 7:26 AM
originally posted by: GDorazio

From a personal reply from Michael to Gery:


Hi Gery,

Those instructions are a bit too strict.


It works fine as long as BITS (background intelligent transfer service) is running, which requires NT, 2000, xp, or w2k3.

It also requires framework 1.1, but it will work with 1.0 though the test cycle for that was not as extensive.


To run on win 9x, you will need to implement a new IDownloader since the one we ship with uses BITS which doesn’t work on 9x