ApplicationDeployProcessor error

Topics: Updater Application Block
Mar 15, 2005 at 6:05 AM
originally posted by: sliu

Hi,
I am trying to implement "Manual Inproc" pattern in my application. I followed the example in the readme.doc however I am having some problem getting it work and here is the scenario:

1. In the manifests.xml file I enabled hashComparision(hmac1) and then included all files that are used by my application.
2. Then I tried to update my client application, which detected that out of all say 25 files in the manifest, 5 need to be downloaded. And UAB downloaded all 5 files w/o problems( I can see them in the UAB download directory)
3. However, when I exited the application, which resumed the activiation, UAB threw exception like this:
<code>
Exception Type: System.IO.FileNotFoundException
Message: Could not find file "C:\Documents and Settings\sliu\Local Settings\Application Data\UAB\downloader\{69e4d530-7e9d-11d9-9669-0800200c9a66}\60a82f23-7948-4cff-a1a8-4b2432ecc0da\foo.dll".
FileName: C:\Documents and Settings\sliu\Local Settings\Application Data\UAB\downloader\{69e4d530-7e9d-11d9-9669-0800200c9a66}\60a82f23-7948-4cff-a1a8-4b2432ecc0da\foo.dll
FusionLog: NULL
TargetSite: Void WinIOError(Int32, System.String)
HelpLink: NULL
Source: mscorlib
</code>

foo.dll was not downloaded because the copy on my client pc has a copy of it with same hash.

When I debugged in the code, I found that although download process filtered files with same hash, The manifest in the updatetask that copies downloaded files was not filtered. It tried to copy all files in the manifest and of course failed.

Did I miss something? Thank you!
Mar 19, 2005 at 6:51 AM
originally posted by: sliu

Has anybody other than myself seen this problem? What udpate/activation stradegy do you currently use?
Any suggestion will be appreciated.
Apr 1, 2005 at 9:01 AM
originally posted by: durben

I have observed the same issue. I have verified that the code properly removes the files which already exisit on the client and match the hash from the manifest. When the manifest is persisted to disk these changes are not saved.

Here is another report of this issue:
file removal from Manifest
http://www.gotdotnet.com/workspaces/messageboard/thread.aspx?id=83c68646-befb-4586-ba9f-fdf1301902f5&threadid=9dfe0a26-031e-4b7f-b95b-3cbbbb469078