Missing References

Topics: CAB & Smart Client Software Factory
Jan 9, 2006 at 9:36 PM
originally posted by: JulioCasal

I made a new CAB Solution using the Guidance Package. But it does not compile because there are missing references to 3 assemblies:

Microsoft.Practices.CompositeUI.WinForms
Microsoft.Practices.SmartClient.UI
Microsoft.Practices.EnterpriseLibrary.Configuration

I know where to find the first two, but I can't find Microsoft.Practices.EnterpriseLibrary.Configuration. I thought it was removed from Enterprise Library. Anyway, why are those references missed?
Jan 10, 2006 at 10:04 AM
originally posted by: eugeniop

The guidance packages are not meant to fully run at this stage. They are meant to provide a preview of the types of tasks that we could automate.

We also never include binary components. You should build the referenced assemblies and the references to the project.

For direction on the application structure, take a look at the RI-1 code.

Also, remember the release criteria for SC-BAT:

Weekly release:
Code compiles and Unit tests pass
Guidance Packages might not run
Documentation might be incomplete or inconsistent

CTP release: (every 3-4 weeks)
Code compiles and Unit tests pass
Guidance Packages will run
Documentation will be consistent
No showstopper bugs
Jan 10, 2006 at 11:02 AM
originally posted by: JulioCasal

Ohh, thank you then. If that was the intention, the weekly release did help me to understand what you are trying to do. Thanks!
Feb 8, 2006 at 12:42 PM
originally posted by: gbsills

It's not a biggy, but you probably want to update the readme.txt files in the root directory and indicate the needed enterprise assemblies.
Feb 8, 2006 at 6:54 PM
originally posted by: kozaczynski

Totally agree. This is an omission that we will fix in the next iteration.