Problem with Workshop Lab 2

Topics: Mobile Client Software Factory
Sep 7, 2006 at 5:59 AM
originally posted by: johnkattenhorn

Hi,

Wonder if anyone can help ? I'm stuck on Lab 2 with the Workshop, it asks you to right-click on the Adventureworks Project and Select Mobile Workshop | Add Launcher.

I do not have this option, i've checked to make sure that i have the Mobile Client Factory enabled but this option does not appear.

Any ideas ?

Thanks

John
Sep 8, 2006 at 11:04 AM
originally posted by: dcazzulino

In the setup instructions for the Workshop, it's stated that you should NOT be using the version of the guidance package provided with the mobile client factory, but rather the one included with the workshop itself, which is a modified version of it, which aids in completing the workshop.

You will find it under the MCSF\GuidancePackage folder.
Sep 11, 2006 at 1:15 AM
originally posted by: johnkattenhorn

Hi,

Thanks for the quick reply, i'm going to try to unregister the guidance and then build and register the guidance supplied with the HOL labs.

However could you point me in the right direction of the readme or whatever which states this should be done as i cannot find it and i'm converned i do not have a complete copy of the Workshop.

Thanks

John
Sep 11, 2006 at 1:17 AM
originally posted by: dcazzulino

This is stated towards the end of the first lab.
Sep 11, 2006 at 1:26 AM
originally posted by: johnkattenhorn

Thanks i'll check it out.

On another point i was wondering if there is any news on the updater block that has been discussed. I'm currently working on a large handheld project and we still trying to decide how to best distribute updates to the application.

Many Thanks

John
Sep 11, 2006 at 1:34 AM
originally posted by: johnkattenhorn

Hi,

I'm looking in the following structure : MCSF Workshop\Day1\Lab1 and looking at Workshop - Lab1.doc

Still can't see any instructures - really sorry maybe im going blind!!! I've tried to unregistered the guidance, compile up the guidance package in the workshop and registering but i'm still missing the extra option.

Thanks

John
Sep 11, 2006 at 1:53 AM
originally posted by: johnkattenhorn

OK, i've found the text i think, it states that you need to install MobileClientFactory.msi.

However i cannot find one in the MCSF Workshop directory structure ?

Can you let me know where i can find the .msi ?

Thanks

John
Sep 11, 2006 at 2:19 AM
originally posted by: johnkattenhorn

Hi,

Right, i've built the Solution in the workshop directory, and then built the installer project.

I then installed the resulting .msi and - bingo!! There's the missing options.

Thanks for your help, i'll try to ask more intelligent questions next time.

John