Errors when deploy drop 11

Topics: Mobile Client Software Factory
Jul 14, 2006 at 12:07 AM
originally posted by: Yinyuzhe

I follow the readme.txt to deploy drop 11, but unfortunately, 4 errors occure:

1,error 93 could not find file“C:\Work\GotDotNet\CodeGallery\Drop11\MobileClient\RIs\RI-1\Main\CS\Src\CustomerModule\bin\Debug\Microsoft.Practices.Mobile.RI-1.CustomerModule.dll” MapModule

2,error 94 The OutputPath property is not set for this project. Please check to make sure that you have specified a valid Configuration/Platform combination. Configuration='' Platform='AnyCPU' CustomerModule

3,error 96 The OutputPath property is not set for this project. Please check to make sure that you have specified a valid Configuration/Platform combination. Configuration='' Platform='AnyCPU' OrderModule

4,error 97 The OutputPath property is not set for this project. Please check to make sure that you have specified a valid Configuration/Platform combination. Configuration='' Platform='AnyCPU' RI-1.Tests

I check it out that 'deploy' column is checked.
Jul 15, 2006 at 9:40 AM
originally posted by: PerVonge

If you literally are just starting I would propose to wait till we release to MSDN, as we are still :-) on track to get it out today, when we it's uploaded look for: http://msdn.microsoft.com/mobileclientfactory or look on http://msdn.microsoft.com/practices
Jul 18, 2006 at 8:25 AM
originally posted by: fkc888

One issue we found was that pressing F5 in the reference application won't necessarily deploy all projects in the solution.
In the case of Mobile CAB applications, the modules are not referenced via project or dll references. The modules are discovered at runtime by examining the ProfileCatalog.xml file in the AWToGoShell application.

Workaround: manually deploy each missing module (OrderModule, CustomerModule, MapModule). To deploy a module, right click on the project in Solution Explorer, and select "Deploy".