Missing several project Guids

Topics: CAB & Smart Client Software Factory
Jun 17, 2006 at 8:34 AM
originally posted by: sklett

Hi,

I have a CAB project that I have been attempting to keep updated with the changing structure of CAB and SC-BAT projects. For example, I just added the new "Library" project.

I'm trying to use the GAT recipes to generate a new module(I have never done this before) and I'm getting a series of exceptions near the end. The exception is stating that it can't find the following:
ShellProjectGuid
CommonProjectGuid
LibraryProjectGuid
ShellProject

So I started to search around in my various project's properties trying to determine where to add this missing GUID. I understand it can't find it, but where do I add them?

Any tips much appreciated.

Thanks for reading!
Steve
Jun 17, 2006 at 8:47 AM
originally posted by: sklett

More info:
If I let it go ahead and finish trying to generate the project it will create using statements like this:
using "PMD".Common;

Also, I have my shell project named something other than shell, so I renamed it and tried again, same errors.
Jun 17, 2006 at 9:15 AM
originally posted by: sklett

Even more info:

I opened the project file in notepad and found a GUID, yay.
I then opened the BankTeller shell project, copied it's GUID into mine and tried again. Same error.

I've been looking over the GAT source, but it's not shedding any light.
Just wanted to give more info to save anyone who might respond from wasting any time with something that has been tried