Unable to Load CustomUI DLL

Topics: CAB & Smart Client Software Factory
Feb 3, 2006 at 6:44 AM
originally posted by: ksunair

I posted this message on the error groups but I didn't get any response so I am putting it here. I did a clean install of CAB and the lab. I tried the first exercise. The build was successful but when I ran, right off the bat I got an error saying "Unable to Load CustomUI dll" I verified the dll got copied over to the project local directory. When I checked the inner exception, it was complaing some error in permissions. Did any one get this message? If so how can I resolve this error?

Thanks.
Feb 3, 2006 at 7:31 AM
originally posted by: ksunair

Here is the exception message
System.IO.FileLoadException was unhandled
Message="Could not load file or assembly 'Microsoft.ApplicationBlocks.CompositeUI, Version=1.0.50630.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))"
Source="ModuleLoaderQuickStart"
FileName="Microsoft.ApplicationBlocks.CompositeUI, Version=1.0.50630.0, Culture=neutral, PublicKeyToken=null"
FusionLog=""
StackTrace:
at ModuleLoaderQuickStart.Program.Main()
at System.AppDomain.nExecuteAssembly(Assembly assembly, String[] args)
at System.AppDomain.ExecuteAssembly(String assemblyFile, Evidence assemblySecurity, String[] args)
at Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssembly()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()
Feb 7, 2006 at 11:50 AM
originally posted by: ksunair

I found the problem. Even though I removed the old CAB, the project files remaind in the computer and my solution was still pointing to the old dll. I changed the dll back to the new dll and it all worked. Sorry for the confusion.
Thanks.