Vista RC1 - CAB Install doesnt

Topics: CAB & Smart Client Software Factory
Oct 12, 2006 at 4:55 AM
originally posted by: mcgomer

I am not able to install the CAB_CS.msi on a clean install of Vista RC1. I am getting an error when the install trys to create the visual studio solution. There is no error message other than and error occured.

At that point Vista rolls back the install so I end up where I started <grin>.

Vista was installed with a format of the sytem. I installed Visual Studio 2005, windows sdk, workflow, and the visual studio extensions for the sdk.

Has anybody else seen this? Is there a doc that goes through the proper order of install if one wants to do CAB on Vista?

Thanks
Paul
Nov 1, 2006 at 2:29 AM
originally posted by: MGoetzke

same error here. no solution yet. have tried to install into different folder to make sure there is no rights violation. will try without uap.
Nov 8, 2006 at 7:32 PM
originally posted by: ChrisRussi

I am having the exact same problem. What on earth can I do to install CAB on Vista RC1. I need it desperately!

Chris
Nov 8, 2006 at 9:51 PM
originally posted by: marianoszklanny

Hi,
Have you seen these posts? They might be helpful for you.

- http://blogs.msdn.com/tomholl/archive/2006/09/15/756747.aspx
- http://rachit.wordpress.com/2006/08/10/july-vista-winfx-gat-gax/

If you are still having problems with the installer and you need to have CAB installed urgently, you can disable the UAC and it will work (NOTE: THIS IS NOT A RECOMMENDED PRACTICE).

Mariano
http://staff.southworks.net/mariano
Nov 10, 2006 at 9:44 AM
originally posted by: mcgomer

Thanks,

Interesting input from them. Looks like there are going to be some changes coming in the install world.

I also was able to isolate the problem to the unit test portions of the solutions.

If I dont install anything related to unit test it seems to install ok. Not a good long term solution, but it might help for the short term.

Paul