CAB & EnterpriseLibrary: ObjectBuilder Versions

Topics: CAB & Smart Client Software Factory
Sep 29, 2006 at 7:47 AM
originally posted by: ForeignerCR

Hello and thanks in advance.

I'm trying to use the CAB along with some classes from the EnterpriseLibrary in my project.
Both CAB and EL are the last released versions.
The problem is that the ObjectBuilder's version included in the in the EL is 1.0.51109.0, while the one included in the CAB is 1.0.51205.0, so I get this error:

Error: Assembly 'Microsoft.Practices.CompositeUI, Version=1.0.51205.0, Culture=neutral, PublicKeyToken=ab318854814bb523' uses 'Microsoft.Practices.ObjectBuilder, Version=1.0.51205.0, Culture=neutral, PublicKeyToken=ab318854814bb523' which has a higher version than referenced assembly 'Microsoft.Practices.ObjectBuilder, Version=1.0.51109.0, Culture=neutral, PublicKeyToken=ab318854814bb523'

How can I work this out?
Can I rebuild the EL using the ObjectBuilder from the CAB, o viceversa without getting into issues?

I really appreciate any help.

FJ
Sep 29, 2006 at 11:59 AM
originally posted by: ForeignerCR

Never mind, I figured it out.
I actually wasn't using the last released EL.
My mistake.