Cannot install CAB Hands On Labs

Topics: CAB & Smart Client Software Factory
Nov 9, 2005 at 5:25 AM
originally posted by: pgloor

I downloaded CabHandsOnLabs1.0.3.zip and tried to install the labs from the extracted CabHandsOnLabs1.0.3.msi on my local drive to the CAB installation folder (October 2005 CTP).

The installation starts but after a while I get the following error message:
"The cabinet file 'Sample.cab' required for this installation is corrupt and cannot be used. This coud indicate a network error, an error reading from the CD-ROM, or a problem with this package".

I cleared the browsers cache and tried to download the file again, but the problem didn't go away. The size of my CabHandsOnLabs1.0.3.msi is 3'378'176 Bytes.

Any idea how to solve this problem?

Peter
Nov 9, 2005 at 6:12 AM
originally posted by: pgloor

Problem solved:

After I changed the ampersand to "and" in both, the program files folder AND the shortcuts in the start menue, the error went away. Documentation states only problems with the program files folder, but not potential problems with ampersands in the shortcuts.

However, the error message is quite strange - I never expected a shortcut problem.

Peter
Nov 9, 2005 at 11:17 PM
originally posted by: dannytuppeny

I have the same problem, and everything already reads "and" instead of &

:-(
Nov 9, 2005 at 11:19 PM
originally posted by: dannytuppeny

Oh, I see what you mean - the start menu path chosen during setup. I've changed that to and too, but still exactly the same error!
Nov 9, 2005 at 11:23 PM
originally posted by: dannytuppeny

The plot thickens!

My start menu reads "Microsoft patterns and practices". If I browser on the filesystem, it also says "and". In the CAB installation, when I browser for shortcuts, the default has an "&". If I go back up the tree, the "and" version doesn't exist - just the & version. If I type "and" over the "&" in the box at the bottom and click ok, exactly the same problem!

I even clicked directly on "Programs" in the start menu, to put the shortcuts there. Same problem!

:-((
Nov 11, 2005 at 7:59 AM
originally posted by: PProvost

A few comments on this thread:

1. The Hands on Labs are for the June drop and will not work unmodified on the October drop. We will have updated labs shortly after we ship the final bits of CAB.

2. Uninstall any installations of CAB and the labs you have previously installed.

3. To get the labs to work with the June drop (aka CTP1), you need to first install CAB CTP 1 and during the install replace the installation folder (not the shortcut folder) with something that doesn't have an ampersand (e.g. c:\program files\microsoft composite ui app block).

4. When you install the labs, make sure you specify the same folder you used in step 3.

Everything should work fine.