Errors!

Topics: CAB & Smart Client Software Factory
Feb 2, 2006 at 8:00 AM
originally posted by: ksunair

Hi All,

In stalled VS 2005 and then downloaded the Dec drop for both block and lab. When I installed the msi for the CAB, installation is failing at the end saying failing to register. That is one. Second, I downloaded the lab and when I compile the first lab I am getting error saying the dll's are not found. When I checked the debug folder of the CAB they were not compiled. I guess that is because of the install failed.

Can any one help me why my install is failing?
Feb 2, 2006 at 12:10 PM
originally posted by: ksunair

Finally I made the download work. It seems my initial install msi file was missing so I had to manually delete the registry key to make the new drop to install correctly.

But all the other P&P when I install it get build as well and why not CAB?

Thanks.
Feb 2, 2006 at 12:13 PM
originally posted by: BradWilsonMSFT

Actually, only one p&p deliverable compiles itself: Enterprise Library. They do this because of the configuration tool.
Feb 2, 2006 at 12:17 PM
originally posted by: ksunair

Thanks and that means we have to build it ourselfs before we start the lab correct?
When I tried build (you can see in another thread), I am getting error on two attributes in the configuration property
IsCollectionKey and RequiredValue. Do you know anything about it? I already checked the help and these two properties are not in the system help.
Feb 2, 2006 at 12:31 PM
originally posted by: BradWilsonMSFT

The labs make direct references to the CAB projects, so when you build the labs, it automatically builds CAB.

The labs should tell you to compile the solution before beginning any work.
Feb 2, 2006 at 12:45 PM
originally posted by: ksunair

Yes Sir, When I tried I got the same error on those 2 attributes I mentioned in the previous mail. I am sure I may be doing something wrong. If not everyone should have got the same issue on the Dec Drop. Previous one worked fine for me.
Feb 2, 2006 at 1:57 PM
originally posted by: ksunair

I uninstalled everything and installed everything back and it seems the error is gone. But now I am getting unable to load dll (for the CustomUI). Here is the message.

System.IO.FileLoadException was unhandled
Message="Could not load file or assembly 'Microsoft.ApplicationBlocks.CompositeUI, Version=1.0.50630.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))"
Source="ModuleLoaderQuickStart"
FileName="Microsoft.ApplicationBlocks.CompositeUI, Version=1.0.50630.0, Culture=neutral, PublicKeyToken=null"
FusionLog=""
StackTrace:
at ModuleLoaderQuickStart.Program.Main()
at System.AppDomain.nExecuteAssembly(Assembly assembly, String[] args)
at System.AppDomain.ExecuteAssembly(String assemblyFile, Evidence assemblySecurity, String[] args)
at Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssembly()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()

Thanks in advance.
Feb 3, 2006 at 6:41 AM
originally posted by: ksunair

Did any one got the above message or just me?