Running published version - workspaces dont load

Topics: CAB & Smart Client Software Factory
Aug 10, 2006 at 3:47 PM
originally posted by: kgreed

I have a problem when I publish my shell application - the workspaces dont load
Can anyone help?
Aug 11, 2006 at 3:11 AM
originally posted by: bphillipsatcrowe

Can you check that the ProfileCatalog.xml file was included in the publish? I had to manually change the "Publish Status" of that file to Include.
Aug 11, 2006 at 11:46 AM
originally posted by: kgreed

Thank you
Found the post on Gotdotnet smart client 17th July 2006 "Click Once deployment problems"
& got it working.

Quoting ForumUserRCC on this post

.... when on the "properties" for the Shell project where you enter your Publish options, I had to first click on the "Application files" button which then presents a screen with all the files included. Scrolling down to the ProfileCatalog.xml file, it is defaults as just a "Data File". Change that to "Include" and part of the "Required" download group.

FYI - I also found that I had to add as a "reference" within the Shell project a reference to all the project DLLs. The Shell may not use them directly, but in order for the build I had to include them as a reference. I didn't see how I could include them since in that same "Application Files" area there wasn't a way to insert a line and add the file.