Can't build CAB with 2005 RTM

Topics: CAB & Smart Client Software Factory
Nov 2, 2005 at 10:35 AM
originally posted by: dplattipswich

I've downloaded and installed CAB, but can't build it because of missing references to Nunit. When I try to install Nunit, it complains about needing .NET FW v2.0.40607. How do I get the Nunit that it needs onto my machine, then build CAB with VS 2005 RTM? Thanx.

DSP
Nov 2, 2005 at 1:14 PM
originally posted by: BradWilsonMSFT

Did you install NUnit 2.2? I don't recall having any problems installing NUnit 2.2 with recent release of .NET 2.0.

40607 is 2.0 Beta 1, and it's really old. I'm surprised the installer would be looking for that.
Nov 2, 2005 at 1:42 PM
originally posted by: dplattipswich

Yes, both 2.2 and 2.2.2 from nunit.com. When I run the msi installer package, it says that it wants that old version and will not install without it.

DSP
Nov 3, 2005 at 5:54 AM
originally posted by: dplattipswich

Even though the message box from the Nunit installer says it wants .NET FW v2.0.40607, the presence of v1.1 makes it install correctly. Problem now solved. Bad, bad error message. Possibly worth including in my forthcoming book Why Software Sucks, due out in June 06 from Addison-Wesley.

DSP