Cannot update disconnected service agent

Topics: Offline Application Block
Dec 10, 2012 at 8:09 PM

Hi,

I have created a disconnected service agent ,but after I update my webservice and build the solution,the wizard of recipe can not show "Type" and "Solutin Preview" when I update disconnected service agent ,and show “in order to run this recipe,you solution must compile, please build your solution and try again”,but I have built.

Any idea on how to fix this?

Dec 11, 2012 at 7:20 PM

Hi,

Based on my understanding, after changing a WebService, you will need to update your Disconnected Service Agent too, like explained in the following section of the documentation:

I this does not help, I believe you could also try to clean your solution manually in order to ensure that your application is being re-builded again from scratch. In order to do so, you could delete the bin and obj folders of all the projects in your solution and after that rebuild the solution again.

I hope this helps,

Damian Cherubini
http://blogs.southworks.net/dcherubini

Dec 15, 2012 at 1:34 AM

Thanks DCherubini,
I have  deleted the bin and obj folders of all the projects in my solution and after that rebuild the solution again.but it is the same question.I'm using vs2010 and scsf for vs2010, the webservice create by java use Axis2,and return entity from webservice sometimes, i don't know whether that is a question.I wan to know whether scsf recipe supply debug

Dec 18, 2012 at 11:45 AM

Hi,

Based on my understanding you should be able to debug the SCSF Guidance Package functionalities by opening the SmartClientFactory Guidance Package solution included in the SCSF source (Guidance Packages folder). And by following the steps mentioned in the HowToDebugGP.txt file, as this will let you run an experimental instance of Visual Studio:

1) Right Click On SmartClientFactoryPackage -> Properties

2) Set "Start External Programe:" to

    C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe  (for 64bit VS)
    C:\Program Files      \Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe  (for 32bit VS)

3) Set "command command line argument:" to
    /rootSuffix Exp

4) On Windows Start Menu:
   Start -> All Programs -> Microsoft Visual Studio 2010 SDK -> Tools -> Reset the Microsoft Visual Studio 2010 Experimental Instance

5) Press Ctrl + F5

I hope you find this handy,

Agustin Adami
http://blogs.southworks.net/aadami